Some services may be impacted by the AWS Outage

Incident Report for Geopointe

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:12 EDT

Monitoring

We have identified issues with the Geocoder, High Performance Assignment Plans, and Insights features within Geopointe, all as a result of the ongoing AWS Outage. We will continue to monitor the situation.
Posted Oct 20, 2025 - 09:53 EDT
This incident affected: Route Planner, Assignment Plans, and The Geocoder.